ME3Tweaks Forums

Modding forum for the Mass Effect series

Client can't connect to server

Mass Effect 3 Private Server Emulator is a replacement for the Origin/Blaze backend that handles the online component of Mass Effect 3.

Moderator: PSE Developer

Postby Eli KIA » Thu Feb 08, 2018 12:33 am

Greetings have lurked and read on here for some time now. I am trying to have my client vm machine connect to my host machine that is also running the game. the host runs fine in online matches and such, i did double check my firewall and set an exception as well as double checking both host files everything seemed as it should be. when i watch the log on the host i can clearly see the client has connected and some data is transferred after the start screen the client will receive the "cannot connect to EA servers error" but i am still able to enter multiplayer to said login screen if i continue to login or create a new account i get a repeat of the error earlier after i confirm the agreement, which seems strange because the client is visible in the log after some investigation i saw the log was throwing this error "[Main Server Handler 2][Handler_1:6E] Error: HandleComponent_1_Command_6E: PNAM is invalid" any input or information on the matter would be appreciated i had some other errors that i corrected but this one does not seem as clear to me thanks :mrgreen:
Eli KIA
 
Posts: 2
Joined: Thu Feb 08, 2018 12:08 am

Postby Erik JS » Sun Feb 11, 2018 2:14 pm

I saw this topic on Friday, but I didn't reply because I was feeling bad that day, and yesterday as well. I think I'm a little better now.

https://www.dropbox.com/s/81o9i3nzuzs6o ... V.zip?dl=0

Use this test version. It'll show more details about this "PNAM is invalid" error.
User avatar
Erik JS
 
Posts: 107
Joined: Sun Jan 10, 2016 8:03 pm
Location: Brazil

Postby Eli KIA » Mon Feb 12, 2018 5:29 am

Not a issue i had a busy weekend myself i did try your test version and like before at the start screen it gives me a cannot connect to EA server error but no error from the log until i enter multiplayer from there when i create a new account and accept the documents i get this from the test log :[Main Server Handler 1] Send Response, len = 12
2018.02.11 22:46:55 [->][INFO] Authentication Component : createAccount
2018.02.11 22:46:55 [Main Server Handler 1] Received request data, len = 26
2018.02.11 22:46:55 [<-][INFO] Authentication Component : createPersona
2018.02.11 22:46:55 [<-][INFO] PNAM : 1 "ME311290"
2018.02.11 22:46:55 [Main Server Handler 1] Send Response, len = 12
2018.02.11 22:46:55 [->][INFO] Authentication Component : createPersona
2018.02.11 22:46:55 [Main Server Handler 1] Received request data, len = 18
2018.02.11 22:46:55 [<-][INFO] Authentication Component : loginPersona
2018.02.11 22:46:55 [<-][INFO] PNAM : 1 ""
2018.02.11 22:46:55 [Main Server Handler 1][Handler_1:6E] Error: HandleComponent_1_Command_6E: PNAM is invalid
2018.02.11 22:46:55 pnam.Value =
2018.02.11 22:46:55
2018.02.11 22:46:55 player.Name =
2018.02.11 22:46:55 [Main Server Handler 1][Handler_1:*] Error:
System.NullReferenceException: Object reference not set to an instance of an object.
2018.02.11 22:47:05 [Main Server Handler 1] Received request data, len = 12
2018.02.11 22:47:05 [<-][INFO] Authentication Component : logout
2018.02.11 22:47:05 [Main Server Handler 1] Send Response, len = 12
2018.02.11 22:47:05 [->][INFO] Authentication Component : logout
Thoughts? not sure if something is missing here.
Eli KIA
 
Posts: 2
Joined: Thu Feb 08, 2018 12:08 am

Postby Erik JS » Mon Feb 12, 2018 9:32 am

Eli KIA wrote:2018.02.11 22:46:55 [->][INFO] Authentication Component : createAccount

2018.02.11 22:46:55 [<-][INFO] Authentication Component : createPersona


You cannot create an account using in-game "create account" feature. You have to log in to an existing profile already created by PSE (the machine where PSE is running must have all profiles from all players who intend to connect to it). See How-To #4.

While PSE responds to "createAccount" and "createPersona", its reply is just an empty message with no fields, no values.
User avatar
Erik JS
 
Posts: 107
Joined: Sun Jan 10, 2016 8:03 pm
Location: Brazil


Return to Mass Effect 3 Private Server Emulator