ME3Tweaks Forums

Modding forum for the Mass Effect series

PSE in hamachi

Mass Effect 3 Private Server Emulator is a replacement for the Origin/Blaze backend that handles the online component of Mass Effect 3.

Moderator: PSE Developer

Postby 4n4kin » Fri Aug 24, 2018 11:42 am

i need help with connecting the PSE through the hamachi

i have no problem setting up redirection through the host setup but i cant set up a redirection path through the client setup. it didnt set ip and close and it didnt open up the ME3PSE window automatically. i tried opening it up manually but it said that

ErrorCode: 10049, NativeErrorCode: 10049, SocketErrorCode: AddressNotAvailable
2018.08.24 18:38:36 [Main Server] Crashed:
System.Net.Sockets.SocketException: The requested address is not valid in its context
ErrorCode: 10049, NativeErrorCode: 10049, SocketErrorCode: AddressNotAvailable

how do you exactly connect to PSE with hamachi?
4n4kin
 
Posts: 3
Joined: Fri Aug 24, 2018 11:30 am

Postby Erik JS » Sun Aug 26, 2018 4:54 pm

You shouldn't open PSE on clients. Just follow the guide:

- Host: setup.exe -> setup for hoster (select whatever local IP given by Hamachi)
- Clients: setup.exe -> setup for client (then insert the host's Hamachi IP)

And keep PSE running in the host... when everyone is done playing the game: setup.exe -> deactivate redirection (to clean Windows' hosts file). Host can instead use F7 from main PSE window.
User avatar
Erik JS
 
Posts: 109
Joined: Sun Jan 10, 2016 8:03 pm
Location: Brazil

Postby 4n4kin » Sun Sep 02, 2018 2:14 pm

But it doesnt work, my friend set it up only as a client and multiplayer doesnt unlock for him, it didnt connect to my server, any solutions?
4n4kin
 
Posts: 3
Joined: Fri Aug 24, 2018 11:30 am

Postby Erik JS » Tue Sep 04, 2018 2:46 am

Did you try the other way? You = client, friend = host.

I'm not sure about what's causing issues in this case. :| I assume you already verified antivirus/firewall permissions, right?
User avatar
Erik JS
 
Posts: 109
Joined: Sun Jan 10, 2016 8:03 pm
Location: Brazil

Postby 4n4kin » Sat Sep 08, 2018 9:45 am

yes we have, we have verified the antivirus and firewall permissions, and yet the one that uses client setup cant use the multiplayer on me3, only the one who is the host can use it while the client cant. Is there a bug or something or is there anyway it can detect there is a client redirection

The symptoms include when finishing the client setup, the setup.exe didnt close or anything. when opening PSE, it said that redirection has been done, so the client side closed the PSE but multiplayer still didnt run.

any suggestions?
4n4kin
 
Posts: 3
Joined: Fri Aug 24, 2018 11:30 am

Postby Erik JS » Sat Sep 08, 2018 2:50 pm

Test PSE's HTTP handler and see what happens.

- Host: open PSE and keep it running;

- Client: open a browser window and type the following in the address bar: «host IP»/abc123

- Check host's PSE. There should be a message saying "File not found: abc123".

- Client: use setup for client. Set up redirection to host's IP.

- Client: from browser, type this address: me3.goscontent.ea.com/123abc

- Check host's PSE for "File not found: 123abc".

Example:
http://www.mediafire.com/view/0po58zli3wdj9hg/pse_http_test1.png
http://www.mediafire.com/view/iyf10p4sjfq45mo/pse_http_test2.png
User avatar
Erik JS
 
Posts: 109
Joined: Sun Jan 10, 2016 8:03 pm
Location: Brazil


Return to Mass Effect 3 Private Server Emulator